Engine cutting out when I indicate

Think you broke it or don't know what to do?
Post Reply
User avatar
chriscbr600rr
I quite like it round here!
Posts: 611
Joined: 07 Feb 2012, 20:42
Location: Milton Keynes

Engine cutting out when I indicate

Post by chriscbr600rr » 25 Jun 2013, 17:51

Hi guys, was riding today and my bike cut out. I thought it was just a bad contact on the connectors on the loom. However after it happened again, and again I noticed it was only when I indicated.

I have just noticed while writing this that when my engine is running all indicators are on solid, then I press indicator switch either way and it cuts then engine. I have to then press off on indicators, switch bike off then it will start and run. They same over and over. Ideas guys??

Sent from my GT-I9300 using Tapatalk 4 Beta

User avatar
herbalisticharry
I quite like it round here!
Posts: 4903
Joined: 30 Apr 2011, 08:34
Location: emneth...nr wisbekistan..cambs

Re: Engine cutting out when I indicate

Post by herbalisticharry » 25 Jun 2013, 17:54

Has it got an alarm/immobiliser ....

Wot did u do before it happened, tank off? Nipped wire? :dunno:


€$¥ l!f€ B0i :farmer:
Image
i'm not racist.............i'll race any fecka....

User avatar
chriscbr600rr
I quite like it round here!
Posts: 611
Joined: 07 Feb 2012, 20:42
Location: Milton Keynes

Re: Engine cutting out when I indicate

Post by chriscbr600rr » 25 Jun 2013, 18:02

Sod all as far as I know. Nothing has changed :dunno: I thought dirty terminal and fuel was cutting out. Now ive realised the indicator has a direct impact on the fuel pump

Sent from my GT-I9300 using Tapatalk 4 Beta

User avatar
herbalisticharry
I quite like it round here!
Posts: 4903
Joined: 30 Apr 2011, 08:34
Location: emneth...nr wisbekistan..cambs

Re: Engine cutting out when I indicate

Post by herbalisticharry » 25 Jun 2013, 18:09

Flasher relay gone wonkey ?????


€$¥ l!f€ B0i :farmer:
Image
i'm not racist.............i'll race any fecka....

User avatar
chriscbr600rr
I quite like it round here!
Posts: 611
Joined: 07 Feb 2012, 20:42
Location: Milton Keynes

Re: Engine cutting out when I indicate

Post by chriscbr600rr » 25 Jun 2013, 18:14

Not a clue. If indicator is disconnected/curcuit broken it wont state/run

Sent from my GT-I9300 using Tapatalk 4 Beta

User avatar
herbalisticharry
I quite like it round here!
Posts: 4903
Joined: 30 Apr 2011, 08:34
Location: emneth...nr wisbekistan..cambs

Re: Engine cutting out when I indicate

Post by herbalisticharry » 25 Jun 2013, 18:20

Check all the earths u can find...


€$¥ l!f€ B0i :farmer:
Image
i'm not racist.............i'll race any fecka....

User avatar
chriscbr600rr
I quite like it round here!
Posts: 611
Joined: 07 Feb 2012, 20:42
Location: Milton Keynes

Re: Engine cutting out when I indicate

Post by chriscbr600rr » 25 Jun 2013, 18:30

Ok I'll try having a look. Do you know which would likely cause it? Or just any?

Sent from my GT-I9300 using Tapatalk 4 Beta

User avatar
esxr7.5
I quite like it round here!
Posts: 3664
Joined: 08 Oct 2011, 13:01

Re: Engine cutting out when I indicate

Post by esxr7.5 » 25 Jun 2013, 19:30

Fecking electrics, don't you just love em!
Do you have a wiring diagram, if so try tracing any wires that have the same earth or power wires between the indicators and fuel pump/relay, maybe a short!
Imagehttp://www.ypel.co.uk
It's not what you ride - Its how you ride it!

User avatar
Doz
I quite like it round here!
Posts: 1043
Joined: 08 Feb 2011, 08:12
Location: Southampton

Re: Engine cutting out when I indicate

Post by Doz » 25 Jun 2013, 21:54

I must be a bit strange, i love fek'n around with electrics. I'm currently building a new loom for my 72 VW Camper. New from front to rear. Shame your not closer I'm sure I could sort that in a couple of hours.
If you have to ask. You wouldn't understand.

User avatar
Armi
I quite like it round here!
Posts: 5522
Joined: 16 Dec 2010, 18:59

Re: Engine cutting out when I indicate

Post by Armi » 26 Jun 2013, 00:31

Don't you just hate it, when people tease you like that Chris :pc:

Here's a thought.stop indicating :whistle:

Just kidding buddy.............got no Fecking idea :tut:
Image

User avatar
Worf
Team Snail Racing
Posts: 2601
Joined: 21 Dec 2012, 15:14

Re: Engine cutting out when I indicate

Post by Worf » 26 Jun 2013, 10:57

esxr7.5 wrote:Fecking electrics, don't you just love em!
Do you have a wiring diagram, if so try tracing any wires that have the same earth or power wires between the indicators and fuel pump/relay, maybe a short!


Bloody sound advice !!!
GSXR750K2 "Team Snail Racing Project"

http://stores.ebay.co.uk/screwloose13
http://screwloose-fasteners.ebid.net/

User avatar
chriscbr600rr
I quite like it round here!
Posts: 611
Joined: 07 Feb 2012, 20:42
Location: Milton Keynes

Re: Engine cutting out when I indicate

Post by chriscbr600rr » 27 Jun 2013, 00:26

Didn't get to look today but have looked at the diagram. I think maybe the relay has melted causing an arch? I will investigate further (as I don't have a choice lol) and armi, thats how I got home, no indication or mirrors. Its like being on the track, just not as safe esp with the worry about bike cutting out mid corner :/

Sent from my GT-I9300 using Tapatalk 4 Beta

Post Reply